icon

We found results for “

WS-2019-0265

Good to know:

icon

Date: September 25, 2019

Wizard-syncronizer, in all versions, is vulnerable to Command Injection. The package does not validate input on the cloneAndSync function and concatenates it to an exec call. This can be abused through a malicious widget containing the payload in the gitURL value or through a MITM attack since the package does not enforce HTTPS. This may allow attackers to run arbitrary commands in the system.

Language: JS

Severity Score

Severity Score

Weakness Type (CWE)

Command Injection

CWE-77

Injection

CWE-74

Top Fix

icon

Upgrade Version

No fix version available

CVSS v3.1

Base Score:
Attack Vector (AV): NETWORK
Attack Complexity (AC): HIGH
Privileges Required (PR): NONE
User Interaction (UI): NONE
Scope (S): UNCHANGED
Confidentiality (C): HIGH
Integrity (I): HIGH
Availability (A): HIGH

Do you need more information?

Contact Us