CVE-2025-61638
Published:February 02, 2026
Updated:November 02, 2026
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki, Wikimedia Foundation Parsoid. This vulnerability is associated with program files includes/parser/Sanitizer.Php, src/Core/Sanitizer.Php.
This issue affects MediaWiki: from * before 1.39.14, 1.43.4, 1.44.1; Parsoid: from * before 0.16.6, 0.20.4, 0.21.1.
Affected Packages
https://github.com/wikimedia/mediawiki.git (GITHUB):
Affected version(s) >=fundraising/REL1_27 <1.39.15Fix Suggestion:
Update to version 1.39.15https://github.com/wikimedia/mediawiki.git (GITHUB):
Affected version(s) =1.44.0 <1.44.1Fix Suggestion:
Update to version 1.44.1https://github.com/wikimedia/mediawiki.git (GITHUB):
Affected version(s) >=1.43.0 <1.43.4Fix Suggestion:
Update to version 1.43.4Related Resources (1)
Do you need more information?
Contact UsWeakness Type (CWE)
Improper Neutralization of Input During Web Page Generation
EPSS
Base Score:
0.27