CVE-2025-6590
Published:February 02, 2026
Updated:October 29, 2026
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/htmlform/fields/HTMLUserTextField.Php.
This issue affects MediaWiki: from * through 1.39.12, 1.42.76 1.43.1, 1.44.0.
Affected Packages
https://github.com/wikimedia/mediawiki.git (GITHUB):
Affected version(s) >=1.43.0 <1.43.2Fix Suggestion:
Update to version 1.43.2https://github.com/wikimedia/mediawiki.git (GITHUB):
Affected version(s) >=1.42.0 <1.42.7Fix Suggestion:
Update to version 1.42.7https://github.com/wikimedia/mediawiki.git (GITHUB):
Affected version(s) >=1.39.0 <1.39.13Fix Suggestion:
Update to version 1.39.13Related Resources (1)
Do you need more information?
Contact UsCVSS v4
Base Score:
4.6
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
ACTIVE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
HIGH
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
3.4
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Weakness Type (CWE)
Exposure of Sensitive Information to an Unauthorized Actor
EPSS
Base Score:
0.37