CVE-2026-108097
Published:October 30, 2026
Updated:November 02, 2026
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.
Affected Packages
drupal/core (PHP):
Affected version(s) >=8.9.0 <10.6.19Fix Suggestion:
Update to version 10.6.19drupal/core (PHP):
Affected version(s) >=11.0.0 <11.3.19Fix Suggestion:
Update to version 11.3.19drupal/core (PHP):
Affected version(s) >=11.4.0 <11.4.10Fix Suggestion:
Update to version 11.4.10Related Resources (5)
Do you need more information?
Contact UsCVSS v4
Base Score:
9.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
9.8
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Use of Externally-Controlled Input to Select Classes or Code
EPSS
Base Score:
0.33