CVE-2026-108500
Published:November 04, 2026
Updated:November 04, 2026
Input validation vulnerability in Apache ActiveMQ configured to use the LDAPAuthorizationMapPlugin allows an authenticated attacker to create or address a destination with a crafted name containing LDAP DN special characters (such as comma, plus, equals, backslash) can manipulate the LDAP search base used for ACL lookups.
This issue affects Apache ActiveMQ: from 6.3.0 before 6.3.3, from 5.19.0 before 5.19.12.
Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
Affected Packages
https://github.com/apache/activemq.git (GITHUB):
Affected version(s) >=activemq-6.0.0 <activemq-6.3.3 || >=activemq-6.1.0 <activemq-6.3.3 || >=activemq-6.2.0 <activemq-6.3.3 || >=activemq-6.3.0 <activemq-6.3.3Fix Suggestion:
Update to version activemq-6.3.3https://github.com/apache/activemq.git (GITHUB):
Affected version(s) >=activemq-4.1.0 <activemq-5.19.12 || =activemq-5.0.0 <activemq-5.19.12 || =activemq-5.1.0 <activemq-5.19.12 || =activemq-5.2.0 <activemq-5.19.12 || >=activemq-5.3.0 <activemq-5.19.12 || >=activemq-5.4.0 <activemq-5.19.12 || >=activemq-5.5.0 <activemq-5.19.12 || =activemq-5.6.0 <activemq-5.19.12 || =activemq-5.7.0 <activemq-5.19.12 || =activemq-5.8.0 <activemq-5.19.12 || >=activemq-5.9.0 <activemq-5.19.12 || >=activemq-5.10.0 <activemq-5.19.12 || >=activemq-5.11.0 <activemq-5.19.12 || >=activemq-5.12.0 <activemq-5.19.12 || >=activemq-5.13.0 <activemq-5.19.12 || >=activemq-5.14.0 <activemq-5.19.12 || >=activemq-5.15.0 <activemq-5.19.12 || >=activemq-5.16.0 <activemq-5.19.12 || >=activemq-5.17.0 <activemq-5.19.12 || >=activemq-5.18.0 <activemq-5.19.12 || >=activemq-5.19.0 <activemq-5.19.12 || >=activemq-parent-5.2 <activemq-5.19.12Fix Suggestion:
Update to version activemq-5.19.12org.apache.activemq:activemq-broker (JAVA):
Affected version(s) >=6.3.0 <6.3.3 || >=6.1.0 <6.3.3 || >=6.2.0 <6.3.3 || >=6.0.0 <6.3.3Fix Suggestion:
Update to version 6.3.3org.apache.activemq:activemq-broker (JAVA):
Affected version(s) >=5.19.0 <5.19.12 || >=5.18.0 <5.19.12 || >=5.12.0 <5.19.12 || >=5.11.0 <5.19.12 || >=5.17.0 <5.19.12 || >=5.10.0 <5.19.12 || >=5.14.0 <5.19.12 || >=5.9.0 <5.19.12 || >=5.13.0 <5.19.12 || >=5.15.0 <5.19.12 || >=5.16.0 <5.19.12 || >=5.8.0 <5.19.12Fix Suggestion:
Update to version 5.19.12Related Resources (3)
Do you need more information?
Contact UsCVSS v4
Base Score:
5.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
5.4
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Improper Input Validation