CVE-2026-111821
Published:November 04, 2026
Updated:November 04, 2026
Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB.
A user can create a durable subscription with a clientId and subscription name that have a combined length > 65,535 (while separately being shorter) on a broker using KahaDB which can cause the broker to shutdown and be unrecoverable.
This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12.
Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
Affected Packages
https://github.com/apache/activemq.git (GITHUB):
Affected version(s) >=activemq-6.0.0 <activemq-6.3.3 || >=activemq-6.1.0 <activemq-6.3.3 || >=activemq-6.2.0 <activemq-6.3.3 || >=activemq-6.3.0 <activemq-6.3.3Fix Suggestion:
Update to version activemq-6.3.3https://github.com/apache/activemq.git (GITHUB):
Affected version(s) >=activemq-5.3.0 <activemq-5.19.12 || =activemq-parent-5.3.2 <activemq-5.19.12 || >=activemq-5.4.0 <activemq-5.19.12 || >=activemq-5.5.0 <activemq-5.19.12 || =activemq-5.6.0 <activemq-5.19.12 || =activemq-5.7.0 <activemq-5.19.12 || =activemq-5.8.0 <activemq-5.19.12 || >=activemq-5.9.0 <activemq-5.19.12 || >=activemq-5.10.0 <activemq-5.19.12 || >=activemq-5.11.0 <activemq-5.19.12 || >=activemq-5.12.0 <activemq-5.19.12 || >=activemq-5.13.0 <activemq-5.19.12 || >=activemq-5.14.0 <activemq-5.19.12 || >=activemq-5.15.0 <activemq-5.19.12 || >=activemq-5.16.0 <activemq-5.19.12 || >=activemq-5.17.0 <activemq-5.19.12 || >=activemq-5.18.0 <activemq-5.19.12 || >=activemq-5.19.0 <activemq-5.19.12Fix Suggestion:
Update to version activemq-5.19.12org.apache.activemq:activemq-kahadb-store (JAVA):
Affected version(s) =5.8.0 <5.19.12 || >=5.10.0 <5.19.12 || >=5.14.0 <5.19.12 || >=5.19.0 <5.19.12 || >=5.12.0 <5.19.12 || >=5.18.0 <5.19.12 || >=5.11.0 <5.19.12 || >=5.13.0 <5.19.12 || >=5.17.0 <5.19.12 || >=5.15.0 <5.19.12 || >=5.9.0 <5.19.12 || >=5.16.0 <5.19.12Fix Suggestion:
Update to version 5.19.12org.apache.activemq:activemq-kahadb-store (JAVA):
Affected version(s) >=6.3.0 <6.3.3 || >=6.0.0 <6.3.3 || >=6.1.0 <6.3.3 || >=6.2.0 <6.3.3Fix Suggestion:
Update to version 6.3.3Related Resources (4)
Do you need more information?
Contact UsCVSS v4
Base Score:
8.7
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
NONE
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.5
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Weakness Type (CWE)
Improper Input Validation