Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-113593
Published:November 03, 2026
Updated:November 04, 2026
An issue was discovered in Django 6.1 before 6.1.3, 6.0 before 6.0.10, and 5.2 before 5.2.19. The "django.middleware.cache.UpdateCacheMiddleware" and the "django.views.decorators.cache.cache_page()" decorator generate identical cache keys for requests that omit a header listed in the response’s "Vary" header and requests that include that header with an empty value, potentially allowing remote attackers to access private data cached for another request. Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected. Django would like to thank Andrew Gonzalez for reporting this issue.
Affected Packages
django (CONDA):
Affected version(s) >=4.1 <5.2.19 || >=2.2 <5.2.19 || >=4.2 <5.2.19 || >=4.0 <5.2.19 || >=2.1 <5.2.19 || >=2.0 <5.2.19 || >=1.6.5 <5.2.19 || >=5.0 <5.2.19 || >=5.1 <5.2.19 || >=1.9.2 <5.2.19 || >=3.1 <5.2.19 || >=3.2 <5.2.19 || >=5.2 <5.2.19 || >=1.8 <5.2.19 || >=3.0 <5.2.19 || >=1.7 <5.2.19 || >=1.11 <5.2.19 || >=1.10 <5.2.19
Fix Suggestion:
Update to version 5.2.19
django (CONDA):
Affected version(s) >=6.0 <6.0.10
Fix Suggestion:
Update to version 6.0.10
django (CONDA):
Affected version(s) >=6.1 <6.1.3
Fix Suggestion:
Update to version 6.1.3
https://github.com/django/django.git (GITHUB):
Affected version(s) >=6.0a1 <6.0.10
Fix Suggestion:
Update to version 6.0.10
https://github.com/django/django.git (GITHUB):
Affected version(s) >=1.0 <5.2.19 || >=1.1 <5.2.19 || >=1.2 <5.2.19 || >=1.3 <5.2.19 || >=1.4 <5.2.19 || >=1.5a1 <5.2.19 || >=1.6a1 <5.2.19 || >=1.7a1 <5.2.19 || >=1.8a1 <5.2.19 || >=1.9a1 <5.2.19 || >=1.10a1 <5.2.19 || >=1.11a1 <5.2.19 || >=2.0a1 <5.2.19 || >=2.1a1 <5.2.19 || >=2.2a1 <5.2.19 || >=3.0a1 <5.2.19 || >=3.1a1 <5.2.19 || >=3.2a1 <5.2.19 || >=4.0a1 <5.2.19 || >=4.1a1 <5.2.19 || >=4.2a1 <5.2.19 || >=5.0a1 <5.2.19 || >=5.1a1 <5.2.19 || >=5.2a1 <5.2.19
Fix Suggestion:
Update to version 5.2.19
https://github.com/django/django.git (GITHUB):
Affected version(s) >=6.1a1 <6.1.3
Fix Suggestion:
Update to version 6.1.3
django (PYTHON):
Affected version(s) >=6.0a1 <6.0.10
Fix Suggestion:
Update to version 6.0.10
django (PYTHON):
Affected version(s) >=6.1a1 <6.1.3
Fix Suggestion:
Update to version 6.1.3
django (PYTHON):
Affected version(s) >=4.1a1 <5.2.19 || >=2.2a1 <5.2.19 || >=1.5 <5.2.19 || >=4.2a1 <5.2.19 || >=4.0a1 <5.2.19 || >=2.1a1 <5.2.19 || >=2.0a1 <5.2.19 || >=1.6 <5.2.19 || >=1.0.1 <5.2.19 || >=5.0a1 <5.2.19 || >=5.1a1 <5.2.19 || >=1.9a1 <5.2.19 || >=3.1a1 <5.2.19 || >=3.2a1 <5.2.19 || >=5.2a1 <5.2.19 || >=1.3 <5.2.19 || >=1.8a1 <5.2.19 || >=3.0a1 <5.2.19 || >=1.4 <5.2.19 || >=1.7 <5.2.19 || >=1.2 <5.2.19 || >=1.11a1 <5.2.19 || >=1.10a1 <5.2.19 || >=1.1 <5.2.19
Fix Suggestion:
Update to version 5.2.19
Do you need more information?
Contact Us
CVSS v4
Base Score:
2.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
3.1
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Weakness Type (CWE)
Use of Cache Containing Sensitive Information