Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-114456
Published:November 04, 2026
Updated:November 04, 2026
Multiple Snowflake client drivers implementing the "authenticator=externalbrowser" single sign-on flow could have allowed an attacker to interfere with a user's login attempt through weaknesses in the local loopback callback listener used to receive the identity provider's response. The listener reflected an arbitrary request's Origin header into its CORS response headers and accepted the first token-bearing request it received during the login window without verifying a CSRF state value bound to that specific login attempt. An attacker able to reach the listener during an active login might have leveraged this to submit a forged callback response, causing the authentication attempt to fail. The fix is available in Snowflake Connector for Python 4.8.0, Snowflake Go Driver v2.3.0, Snowflake JDBC Driver 4.4.0 (including the snowflake-jdbc-fips and snowflake-jdbc-thin artifacts), Snowflake Node.js Driver 3.4.0, Snowflake Connector for .NET 6.3.0, Snowflake ODBC Driver 4.0.0, Snowflake PHP PDO Driver 4.3.0, and libsnowflakeclient 2.11.1. Go v1 users must migrate to the latest major version of the module. Users must manually upgrade.
Affected Packages
snowflake-connector-python (CONDA):
Affected version(s) >=1.6.12 <4.8.0 || >=2.0.0 <4.8.0 || >=3.0.1 <4.8.0 || >=4.0.0 <4.8.0
Fix Suggestion:
Update to version 4.8.0
Snowflake.Data (DOT_NET):
Affected version(s) >=4.0.0 <6.3.0 || >=3.0.0 <6.3.0 || >=5.0.0 <6.3.0 || >=1.0.12.0 <6.3.0 || >=6.0.0 <6.3.0 || >=2.0.0.0 <6.3.0
Fix Suggestion:
Update to version 6.3.0
https://github.com/snowflakedb/libsnowflakeclient.git (GITHUB):
Affected version(s) >=v2.1.0 <v2.11.0
Fix Suggestion:
Update to version v2.11.0
https://github.com/snowflakedb/snowflake-connector-python.git (GITHUB):
Affected version(s) >=v1.4.4 <v4.8.0 || >=v2.0.0 <v4.8.0 || =v2.25 <v4.8.0 || >=v3.0.0 <v4.8.0 || >=v4.0.0 <v4.8.0
Fix Suggestion:
Update to version v4.8.0
https://github.com/snowflakedb/snowflake-jdbc.git (GITHUB):
Affected version(s) >=v3.2.3 <v4.4.0 || >=3.13.21 <v4.4.0 || >=v4.0.0 <v4.4.0
Fix Suggestion:
Update to version v4.4.0
https://github.com/snowflakedb/snowflake-connector-nodejs.git (GITHUB):
Affected version(s) >=v1.6.0 <v3.4.0 || >=v2.0.0 <v3.4.0 || >=v3.0.0 <v3.4.0
Fix Suggestion:
Update to version v3.4.0
https://github.com/snowflakedb/snowflake-connector-net.git (GITHUB):
Affected version(s) >=v1.0.12 <v6.3.0 || >=v2.0.0 <v6.3.0 || =2.0.17 <v6.3.0 || >=v3.0.0 <v6.3.0 || >=v4.0.0 <v6.3.0 || >=v5.0.0 <v6.3.0 || >=v6.0.0 <v6.3.0
Fix Suggestion:
Update to version v6.3.0
https://github.com/snowflakedb/gosnowflake.git (GITHUB):
Affected version(s) >=v1.1.5 <v2.3.0
Fix Suggestion:
Update to version v2.3.0
github.com/snowflakedb/gosnowflake/v2 (GO):
Affected version(s) >=v2.0.0 <v2.3.0
Fix Suggestion:
Update to version v2.3.0
net.snowflake:snowflake-jdbc-fips (JAVA):
Affected version(s) >=3.12.3 <4.4.0 || >=4.0.0 <4.4.0
Fix Suggestion:
Update to version 4.4.0
net.snowflake:snowflake-jdbc-thin (JAVA):
Affected version(s) >=3.14.5 <4.4.0 || >=4.0.0 <4.4.0
Fix Suggestion:
Update to version 4.4.0
net.snowflake:snowflake-jdbc (JAVA):
Affected version(s) >=4.0.0 <4.4.0 || >=3.2.3 <4.4.0
Fix Suggestion:
Update to version 4.4.0
snowflake-sdk (NPM):
Affected version(s) >=2.0.0 <3.4.0 || >=1.6.0 <3.4.0 || >=3.0.0 <3.4.0
Fix Suggestion:
Update to version 3.4.0
snowflake.data (NUGET):
Affected version(s) >=4.0.0 <6.3.0 || >=6.0.0 <6.3.0 || >=1.0.12 <6.3.0 || >=5.0.0 <6.3.0 || >=2.0.0 <6.3.0 || >=3.0.0 <6.3.0
Fix Suggestion:
Update to version 6.3.0
snowflake-connector-python (PYTHON):
Affected version(s) >=1.4.5 <4.8.0 || >=2.0.0 <4.8.0 || >=3.0.0 <4.8.0 || >=4.0.0 <4.8.0
Fix Suggestion:
Update to version 4.8.0
Do you need more information?
Contact Us
CVSS v4
Base Score:
7.1
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
NONE
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.5
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Weakness Type (CWE)
Origin Validation Error