Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-115190
Published:October 26, 2026
Updated:October 29, 2026
An insecure deserialization (PHP object injection) vulnerability exists in Mautic's handling of segment filters and custom field properties. Several code paths that read these stored values from the database deserialize them without restricting which PHP classes may be instantiated, instead of using Mautic's safe deserialization helper. An attacker who is able to store a crafted serialized value in these segment filter or custom field properties can cause arbitrary PHP objects to be instantiated when Mautic later processes the data, for example during segment evaluation, contact export, or custom field API requests. Combined with gadget chains available in Mautic's dependencies, this could allow an attacker to execute arbitrary code on the server, read, modify, or delete data stored in the Mautic instance, including contact data, and affect its availability. Exploitation requires high privileges or an existing ability to write to the affected stored data.
Affected Packages
https://github.com/mautic/mautic.git (GITHUB):
Affected version(s) >=6.0.0-alpha <6.0.10
Fix Suggestion:
Update to version 6.0.10
https://github.com/mautic/mautic.git (GITHUB):
Affected version(s) >=5.0.0-alpha <5.2.12
Fix Suggestion:
Update to version 5.2.12
https://github.com/mautic/mautic.git (GITHUB):
Affected version(s) >=7.0.0-alpha <7.2.0
Fix Suggestion:
Update to version 7.2.0
mautic/core (PHP):
Affected version(s) >=5.0.0-alpha <5.2.12
Fix Suggestion:
Update to version 5.2.12
mautic/core (PHP):
Affected version(s) >=7.0.0-alpha <7.2.0
Fix Suggestion:
Update to version 7.2.0
mautic/core (PHP):
Affected version(s) >=6.0.0-alpha <6.0.10
Fix Suggestion:
Update to version 6.0.10
mautic/core-lib (PHP):
Affected version(s) >=7.0.0-alpha <7.2.0
Fix Suggestion:
Update to version 7.2.0
mautic/core-lib (PHP):
Affected version(s) >=6.0.0-alpha <6.0.10
Fix Suggestion:
Update to version 6.0.10
mautic/core-lib (PHP):
Affected version(s) >=5.0.0-alpha <5.2.12
Fix Suggestion:
Update to version 5.2.12
Do you need more information?
Contact Us
CVSS v4
Base Score:
8.9
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
NONE
Privileges Required
HIGH
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
HIGH
Subsequent System Integrity
HIGH
Subsequent System Availability
HIGH
CVSS v3
Base Score:
8
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
HIGH
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Deserialization of Untrusted Data
EPSS
Base Score:
0.49