Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-115884
Published:October 12, 2026
Updated:October 28, 2026
GoAhead's verifyClientCertificate() (src/openssl.c) checks the client-certificate chain depth only when the verifier has not already reported an error. When built against LibreSSL's legacy verifier (3.2.x, 3.3.2-3.3.6) with VERIFY_PEER=1 and VERIFY_ISSUER=0, an attacker can present a self-signed chain longer than the limit of 10 and pass mutual TLS without any trusted key. OpenSSL builds are not affected. Affects versions up to and including 6.1.0; fixed in 6.1.1.
Affected Packages
https://github.com/embedthis/goahead.git (GITHUB):
Affected version(s) >=v6.0.4 <v6.1.1
Fix Suggestion:
Update to version v6.1.1
Do you need more information?
Contact Us
CVSS v4
Base Score:
9.1
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.4
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Weakness Type (CWE)
Improper Authentication
Improper Certificate Validation
Improper Check for Unusual or Exceptional Conditions