Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-116010
Published:October 24, 2026
Updated:October 30, 2026
RosarioSIS before 12.9.1 contains a missing authorization vulnerability that allows authenticated teachers to write records for students outside their course period by supplying arbitrary student IDs. Attackers can modify the st_arr, values, or attendance POST arrays in MakeReferral.php, EnterEligibility.php, InputFinalGrades.php, and TakeAttendance.php to create referrals, eligibility codes, attendance and final grades for any student in the school.
Affected Packages
https://github.com/francoisjacquet/rosariosis.git (GITHUB):
Affected version(s) >=v1.2 <v12.9.1 || >=v2.0b <v12.9.1 || >=v3.0 <v12.9.1 || >=v4.0-beta <v12.9.1 || >=v5.0-beta2 <v12.9.1 || >=v6.0-beta <v12.9.1 || >=v7.0-beta <v12.9.1 || >=v8.0 <v12.9.1 || >=v9.0 <v12.9.1 || >=v10.1 <v12.9.1 || >=v11.0 <v12.9.1 || >=v12.0 <v12.9.1 || >=2.9.8 <v12.9.1 || =5.0-beta <v12.9.1
Fix Suggestion:
Update to version v12.9.1
francoisjacquet/rosariosis (PHP):
Affected version(s) >=v10.1 <v12.9.1 || >=v5.0-beta3 <v12.9.1 || >=v6.0-beta <v12.9.1 || >=v8.0 <v12.9.1 || >=v7.0-beta <v12.9.1 || >=v11.0 <v12.9.1 || >=v9.0 <v12.9.1 || >=v12.0 <v12.9.1
Fix Suggestion:
Update to version v12.9.1
Do you need more information?
Contact Us
CVSS v4
Base Score:
5.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
4.3
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Authorization Bypass Through User-Controlled Key
EPSS
Base Score:
0.20