CVE-2026-116145
Published:October 25, 2026
Updated:October 27, 2026
ImageMagick before 6.9.13-58 and 7.x before 7.1.2-32 contains a security policy bypass caused by an incomplete fix for the policy bypass reported in GHSA-jjp4-3fwf-393j. An attacker able to supply input to ImageMagick can evade configured security policy restrictions, allowing operations the policy was intended to block.
Affected Packages
https://github.com/ImageMagick/ImageMagick6.git (GITHUB):
Affected version(s) >=6.9.4-0 <6.9.13-58Fix Suggestion:
Update to version 6.9.13-58https://github.com/ImageMagick/ImageMagick.git (GITHUB):
Affected version(s) >=7.0.1-0 <7.1.2-33Fix Suggestion:
Update to version 7.1.2-33Related Resources (2)
Do you need more information?
Contact UsCVSS v4
Base Score:
1.8
Attack Vector
LOCAL
Attack Complexity
HIGH
Attack Requirements
PRESENT
Privileges Required
HIGH
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
LOW
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
3.9
Attack Vector
LOCAL
Attack Complexity
HIGH
Privileges Required
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Weakness Type (CWE)
Protection Mechanism Failure
EPSS
Base Score:
0.11