CVE-2026-116148
Published:October 25, 2026
Updated:October 27, 2026
ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains an injection vulnerability in the MVG encoder, which does not properly neutralize user-specified drawing options before writing them into generated MVG output. Attackers who can supply drawing options can inject arbitrary MVG drawing commands into the resulting MVG file.
Affected Packages
https://github.com/ImageMagick/ImageMagick6.git (GITHUB):
Affected version(s) >=6.9.4-0 <6.9.13-58Fix Suggestion:
Update to version 6.9.13-58https://github.com/ImageMagick/ImageMagick.git (GITHUB):
Affected version(s) >=7.0.1-0 <7.1.2-33Fix Suggestion:
Update to version 7.1.2-33Related Resources (2)
Do you need more information?
Contact UsCVSS v4
Base Score:
4.8
Attack Vector
LOCAL
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
LOW
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
3.6
Attack Vector
LOCAL
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Weakness Type (CWE)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
EPSS
Base Score:
0.14