CVE-2026-116161
Published:October 25, 2026
Updated:October 26, 2026
Parse Server before 8.6.103 and 9.0.0 before 9.10.5-alpha.4 contains an information disclosure vulnerability in LiveQuery. Its subscription hash omits constraints next to a $or operator, including the _Session owner filter and beforeSubscribe constraints, so distinct subscriptions are grouped together. Authenticated clients subscribing with $or queries can receive other users' events, including session tokens usable for impersonation.
Affected Packages
https://github.com/parse-community/parse-server.git (GITHUB):
Affected version(s) >=8.0.0-alpha.1 <8.6.103Fix Suggestion:
Update to version 8.6.103https://github.com/parse-community/parse-server.git (GITHUB):
Affected version(s) >=9.0.0-alpha.1 <9.10.5Fix Suggestion:
Update to version 9.10.5parse-server (NPM):
Affected version(s) >=8.0.0-alpha.1 <8.6.103Fix Suggestion:
Update to version 8.6.103parse-server (NPM):
Affected version(s) >=9.0.0-alpha.1 <9.10.5Fix Suggestion:
Update to version 9.10.5Related Resources (2)
Do you need more information?
Contact UsCVSS v4
Base Score:
6
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.5
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Weakness Type (CWE)
Exposure of Sensitive Information to an Unauthorized Actor