Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-116163
Published:October 25, 2026
Updated:October 29, 2026
Parse Server before 8.6.102 and 9.0.0 before 9.10.5-alpha.2 contains an authentication bypass because the validateSetUp, validateLogin, and validateUpdate methods of custom adapters subclassing AuthAdapter are never called, and an inherited default that accepts any authData is used instead. Attackers can supply arbitrary authData to sign up, link identities, log in as existing users, or skip custom additional authentication factors.
Affected Packages
https://github.com/parse-community/parse-server.git (GITHUB):
Affected version(s) >=9.0.0-alpha.1 <9.10.5
Fix Suggestion:
Update to version 9.10.5
https://github.com/parse-community/parse-server.git (GITHUB):
Affected version(s) >=8.0.0-alpha.1 <8.6.102
Fix Suggestion:
Update to version 8.6.102
parse-server (NPM):
Affected version(s) >=8.0.0-alpha.1 <8.6.102
Fix Suggestion:
Update to version 8.6.102
parse-server (NPM):
Affected version(s) >=9.0.0-alpha.1 <9.10.5
Fix Suggestion:
Update to version 9.10.5
Do you need more information?
Contact Us
CVSS v4
Base Score:
9.1
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.4
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Weakness Type (CWE)
Improper Authentication
EPSS
Base Score:
0.28