CVE-2026-116176
Published:October 25, 2026
Updated:October 29, 2026
vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the X-Request-Id header. Attackers can make a P2pNcclConnector prefill worker ZMQ-connect to an attacker host, leaking the NCCL unique_id and KV-cache tensors or blocking the worker.
Affected Packages
vllm (CONDA):
Affected version(s) >=0.9.2 <0.24.0Fix Suggestion:
Update to version 0.24.0https://github.com/vllm-project/vllm.git (GITHUB):
Affected version(s) >=v0.9.2 <v0.24.0Fix Suggestion:
Update to version v0.24.0vllm (PYTHON):
Affected version(s) >=0.9.2 <0.24.0Fix Suggestion:
Update to version 0.24.0Related Resources (2)
Do you need more information?
Contact UsCVSS v4
Base Score:
8.8
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
NONE
Vulnerable System Availability
LOW
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
8.2
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
LOW
Weakness Type (CWE)
Server-Side Request Forgery
EPSS
Base Score:
0.32