CVE-2026-116178
Published:October 25, 2026
Updated:October 26, 2026
vLLM from 0.20.0 before 0.30.0 contains a denial of service vulnerability that allows remote attackers to crash the engine by sending inconsistent multimodal metadata to the disaggregated /inference/v1/generate endpoint. Attackers can replay a valid multimodal item with repeated or overlapping mm_placeholders ranges or mismatched kwargs_data and mm_hashes lists, producing a negative text span in Qwen2.5-VL position construction that terminates the engine.
Affected Packages
vllm (CONDA):
Affected version(s) >=0.20.0 <0.30.0Fix Suggestion:
Update to version 0.30.0https://github.com/vllm-project/vllm.git (GITHUB):
Affected version(s) >=v0.20.0 <v0.30.0Fix Suggestion:
Update to version v0.30.0vllm (PYTHON):
Affected version(s) >=0.20.0 <0.30.0Fix Suggestion:
Update to version 0.30.0Related Resources (2)
Do you need more information?
Contact UsCVSS v4
Base Score:
8.2
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
NONE
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
5.9
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Weakness Type (CWE)
Improper Input Validation