CVE-2026-116593
Published:October 28, 2026
Updated:November 02, 2026
Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations.
Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime.
An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker.
Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.
Affected Packages
https://github.com/apache/kafka.git (GITHUB):
Affected version(s) >=4.3.0-rc0 <4.3.2Fix Suggestion:
Update to version 4.3.2https://github.com/apache/kafka.git (GITHUB):
Affected version(s) >=4.2.0-rc0 <4.2.2Fix Suggestion:
Update to version 4.2.2org.apache.kafka:connect-runtime (JAVA):
Affected version(s) >=4.2.0 <4.2.2Fix Suggestion:
Update to version 4.2.2org.apache.kafka:connect-runtime (JAVA):
Affected version(s) >=4.3.0 <4.3.2Fix Suggestion:
Update to version 4.3.2Related Resources (3)
Do you need more information?
Contact UsCVSS v4
Base Score:
7.1
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.5
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
EPSS
Base Score:
0.23