Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-117614
Published:October 28, 2026
Updated:November 02, 2026
Jenkins 2.587 and earlier, LTS 2.580.1 and earlier converts the launch commands in older agent configurations into launchers provided by the Command Agent Launcher Plugin without checking whether they have been approved by an administrator, allowing attackers with Agent/Configure permission to execute arbitrary code in the context of the Jenkins controller JVM.
Affected Packages
https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.580 <jenkins-2.580.2
Fix Suggestion:
Update to version jenkins-2.580.2
https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.581 <jenkins-2.588
Fix Suggestion:
Update to version jenkins-2.588
org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.581 <2.588
Fix Suggestion:
Update to version 2.588
org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.580 <2.580.2
Fix Suggestion:
Update to version 2.580.2
Do you need more information?
Contact Us
CVSS v4
Base Score:
8.6
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
HIGH
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.2
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Missing Authorization
EPSS
Base Score:
0.21