Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-117619
Published:October 28, 2026
Updated:November 01, 2026
Jenkins 2.587 and earlier, LTS 2.580.1 and earlier allows requests authenticated using HTTP Basic authentication, including with an API token, to obtain a "remember me" cookie, allowing attackers who have obtained a user's API token to retain access to Jenkins using a "remember me" cookie after the API token is revoked or expires.
Affected Packages
https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.581 <jenkins-2.588
Fix Suggestion:
Update to version jenkins-2.588
https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.277.1 <jenkins-2.580.2 || >=jenkins-2.580.1-rc <jenkins-2.580.2
Fix Suggestion:
Update to version jenkins-2.580.2
org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.266 <2.580.2 || >=2.580 <2.580.2
Fix Suggestion:
Update to version 2.580.2
org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.581 <2.588
Fix Suggestion:
Update to version 2.588
Do you need more information?
Contact Us
CVSS v4
Base Score:
8.6
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
8.1
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
EPSS
Base Score:
0.22