CVE-2026-117620
Published:October 28, 2026
Updated:October 29, 2026
Jenkins 2.587 and earlier, LTS 2.580.1 and earlier allows attackers with Overall/Read permission to trigger warnings in the "Manage Old Data" feature that can be acted on by administrators to inject attacker-controlled data, overriding existing user account information, including login passwords.
Affected Packages
https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.581 <jenkins-2.588Fix Suggestion:
Update to version jenkins-2.588https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.580.1-rc <jenkins-2.580.2Fix Suggestion:
Update to version jenkins-2.580.2org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.580 <2.580.2Fix Suggestion:
Update to version 2.580.2org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.581 <2.588Fix Suggestion:
Update to version 2.588Related Resources (1)
Do you need more information?
Contact UsCVSS v4
Base Score:
8.5
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
ACTIVE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
8
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH