Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-117622
Published:October 28, 2026
Updated:October 29, 2026
Jenkins 2.587 and earlier, LTS 2.580.1 and earlier allows agents to send exceptions implementing the Stapler HttpResponse interface to the controller, resulting in a cross-site scripting (XSS) vulnerability exploitable by attackers in control of agent processes.
Affected Packages
https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.581 <jenkins-2.588
Fix Suggestion:
Update to version jenkins-2.588
https://github.com/jenkinsci/jenkins.git (GITHUB):
Affected version(s) >=jenkins-2.580.1-rc <jenkins-2.580.2
Fix Suggestion:
Update to version jenkins-2.580.2
org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.580 <2.580.2
Fix Suggestion:
Update to version 2.580.2
org.jenkins-ci.main:jenkins-core (JAVA):
Affected version(s) >=2.581 <2.588
Fix Suggestion:
Update to version 2.588
Do you need more information?
Contact Us
CVSS v4
Base Score:
8.6
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
PASSIVE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
8
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH