Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-118244
Published:October 28, 2026
Updated:October 30, 2026
Highcharts JS is a JavaScript charting library based on SVG. From 12.0.0 until 12.6.1 and 13.1.0, Highcharts falls back to assigning raw markup to innerHTML when DOMParser cannot return a document, before its allow-list is applied. In Chromium, the Trusted Types callback can throw while a beforeprint handler runs, so a page that redraws a chart during beforeprint can insert untrusted HTML text options into the hosting document. Event handlers in that markup then run in the page origin when printing begins. The issue affects HTML-rendered titles, labels, data labels, responsive text, and the Stock, Maps, and Gantt products shipped in the same package. This issue is fixed in 12.6.1 and 13.1.0.
Affected Packages
https://github.com/highcharts/highcharts.git (GITHUB):
Affected version(s) >=v13.0.0 <v13.1.0
Fix Suggestion:
Update to version v13.1.0
https://github.com/highcharts/highcharts.git (GITHUB):
Affected version(s) >=grid-v3.0.0 <grid-v3.2.0
Fix Suggestion:
Update to version grid-v3.2.0
https://github.com/highcharts/highcharts.git (GITHUB):
Affected version(s) >=dashboards-v4.0.0 <dashboards-v4.2.2
Fix Suggestion:
Update to version dashboards-v4.2.2
highcharts (NPM):
Affected version(s) >=12.0.0 <12.6.1
Fix Suggestion:
Update to version 12.6.1
@highcharts/dashboards (NPM):
Affected version(s) >=4.0.0 <4.2.2
Fix Suggestion:
Update to version 4.2.2
@highcharts/grid-pro (NPM):
Affected version(s) >=3.0.0 <3.2.0
Fix Suggestion:
Update to version 3.2.0
@highcharts/grid-lite (NPM):
Affected version(s) >=3.0.0 <3.2.0
Fix Suggestion:
Update to version 3.2.0
highcharts (NPM):
Affected version(s) >=13.0.0-beta.0 <13.1.0
Fix Suggestion:
Update to version 13.1.0
Do you need more information?
Contact Us
CVSS v4
Base Score:
7.2
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
LOW
User Interaction
ACTIVE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
NONE
Subsequent System Confidentiality
LOW
Subsequent System Integrity
LOW
Subsequent System Availability
NONE
CVSS v3
Base Score:
8.7
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Weakness Type (CWE)
Improper Neutralization of Input During Web Page Generation
EPSS
Base Score:
0.34