Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-118256
Published:October 28, 2026
Updated:October 29, 2026
Vue I18n is the internationalization plugin for Vue.js. From 9.0.0-beta.5 until 11.4.14 and 12.0.0-alpha.5, enabling escapeParameter, called escapeParameterHtml in the Legacy API, does not escape named interpolation values when the same translation call supplies both list and named values because escapeParams() processes only the list branch. Applications that render translations as HTML and pass untrusted named values with a list can insert attacker-controlled markup, including phishing links, forms, and layout changes, and can permit script execution when combined with the srcdoc sanitizer bypass or on releases without the sanitizer. This issue is fixed in versions 11.4.14 and 12.0.0-alpha.5.
Affected Packages
vue-i18n (CDN_JS):
Affected version(s) >=12.0.0-alpha.1 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
vue-i18n (CDN_JS):
Affected version(s) >=11.0.0-beta.0 <11.4.14 || >=10.0.0-alpha.1 <11.4.14 || >=9.1.0 <11.4.14 || >=9.0.0-beta.5 <11.4.14
Fix Suggestion:
Update to version 11.4.14
https://github.com/intlify/vue-i18n.git (GITHUB):
Affected version(s) >=v12.0.0-alpha.1 <v12.0.0-alpha.5
Fix Suggestion:
Update to version v12.0.0-alpha.5
https://github.com/intlify/vue-i18n.git (GITHUB):
Affected version(s) >=v9.0.0-beta.5 <v11.4.14 || >=v10.0.0-alpha.1 <v11.4.14 || >=v11.0.0-beta.0 <v11.4.14
Fix Suggestion:
Update to version v11.4.14
@intlify/vue-i18n-core (NPM):
Affected version(s) >=11.0.0-beta.0 <11.4.14 || >=10.0.0-alpha.1 <11.4.14 || >=9.2.0-alpha.7 <11.4.14
Fix Suggestion:
Update to version 11.4.14
vue-i18n (NPM):
Affected version(s) >=11.0.0-beta.0 <11.4.14 || >=10.0.0-alpha.1 <11.4.14 || >=9.1.0 <11.4.14 || >=9.0.0-beta.5 <11.4.14
Fix Suggestion:
Update to version 11.4.14
@intlify/core-base (NPM):
Affected version(s) >=11.0.0-beta.0 <11.4.14 || >=9.0.0-beta.12 <11.4.14 || >=10.0.0-alpha.1 <11.4.14
Fix Suggestion:
Update to version 11.4.14
petite-vue-i18n (NPM):
Affected version(s) >=12.0.0-alpha.1 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
petite-vue-i18n (NPM):
Affected version(s) >=11.0.0-beta.0 <11.4.14 || >=10.0.0-alpha.1 <11.4.14 || >=9.2.0-alpha.7 <11.4.14
Fix Suggestion:
Update to version 11.4.14
@intlify/core (NPM):
Affected version(s) >=11.0.0-beta.0 <11.4.14 || >=10.0.0-alpha.1 <11.4.14 || >=9.0.0-beta.10 <11.4.14
Fix Suggestion:
Update to version 11.4.14
@intlify/vue-i18n-core (NPM):
Affected version(s) >=12.0.0-alpha.1 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
vue-i18n (NPM):
Affected version(s) >=12.0.0-alpha.1 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
@intlify/core (NPM):
Affected version(s) >=12.0.0-alpha.1 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
@intlify/core-base (NPM):
Affected version(s) >=12.0.0-alpha.1 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
Do you need more information?
Contact Us
CVSS v4
Base Score:
2.1
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
ACTIVE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
LOW
Subsequent System Availability
NONE
CVSS v3
Base Score:
4.7
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Improper Neutralization of Input During Web Page Generation
Improper Encoding or Escaping of Output