Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-118257
Published:October 28, 2026
Updated:October 29, 2026
Vue I18n is the internationalization plugin for Vue.js. From 11.1.10 until 11.4.14 and from 12.0.0-alpha.4 until 12.0.0-alpha.5, sanitizeTranslatedHtml() escapes markup and event-handler text inside an iframe srcdoc value but leaves the srcdoc attribute active. Browsers decode the character references and parse the value as a same-origin nested HTML document, allowing attacker-controlled parameters or translation content placed in srcdoc to execute script when applications enable escapeParameter and render translations as HTML through v-html. Versions 9.14.5 and 10.0.8 are also affected and are no longer supported, while i18n-t rendering is not affected. This issue is fixed in versions 11.4.14 and 12.0.0-alpha.5.
Affected Packages
vue-i18n (CDN_JS):
Affected version(s) =9.14.5 <11.4.14 || =10.0.8 <11.4.14 || >=11.1.10 <11.4.14
Fix Suggestion:
Update to version 11.4.14
vue-i18n (CDN_JS):
Affected version(s) =12.0.0-alpha.4 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
https://github.com/intlify/vue-i18n.git (GITHUB):
Affected version(s) =v9.14.5 <v11.4.14 || =v10.0.8 <v11.4.14 || >=v11.1.10 <v11.4.14
Fix Suggestion:
Update to version v11.4.14
https://github.com/intlify/vue-i18n.git (GITHUB):
Affected version(s) =v12.0.0-alpha.4 <v12.0.0-alpha.5
Fix Suggestion:
Update to version v12.0.0-alpha.5
@intlify/vue-i18n-core (NPM):
Affected version(s) =9.14.5 <11.4.14 || =10.0.8 <11.4.14 || >=11.1.10 <11.4.14
Fix Suggestion:
Update to version 11.4.14
@intlify/core (NPM):
Affected version(s) =12.0.0-alpha.4 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
vue-i18n (NPM):
Affected version(s) =9.14.5 <11.4.14 || =10.0.8 <11.4.14 || >=11.1.10 <11.4.14
Fix Suggestion:
Update to version 11.4.14
vue-i18n (NPM):
Affected version(s) =12.0.0-alpha.4 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
@intlify/vue-i18n-core (NPM):
Affected version(s) =12.0.0-alpha.4 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
@intlify/shared (NPM):
Affected version(s) =12.0.0-alpha.4 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
@intlify/core-base (NPM):
Affected version(s) =12.0.0-alpha.4 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
petite-vue-i18n (NPM):
Affected version(s) =12.0.0-alpha.4 <12.0.0-alpha.5
Fix Suggestion:
Update to version 12.0.0-alpha.5
@intlify/shared (NPM):
Affected version(s) =9.14.5 <11.4.14 || =10.0.8 <11.4.14 || >=11.1.10 <11.4.14
Fix Suggestion:
Update to version 11.4.14
petite-vue-i18n (NPM):
Affected version(s) =9.14.5 <11.4.14 || =10.0.8 <11.4.14 || >=11.1.10 <11.4.14
Fix Suggestion:
Update to version 11.4.14
@intlify/core (NPM):
Affected version(s) =9.14.5 <11.4.14 || =10.0.8 <11.4.14 || >=11.1.10 <11.4.14
Fix Suggestion:
Update to version 11.4.14
@intlify/core-base (NPM):
Affected version(s) =9.14.5 <11.4.14 || =10.0.8 <11.4.14 || >=11.1.10 <11.4.14
Fix Suggestion:
Update to version 11.4.14
Do you need more information?
Contact Us
CVSS v4
Base Score:
6.9
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
LOW
Subsequent System Integrity
LOW
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.2
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Improper Neutralization of Input During Web Page Generation
Improper Encoding or Escaping of Output