CVE-2026-118514
Published:November 06, 2026
Updated:November 06, 2026
In Symfony http-foundation prior to versions 5.4.56, 6.4.50, 7.4.23, and 8.1.11, Symfony\Component\HttpFoundation\RequestMatcher, and RequestMatcher\MethodRequestMatcher which replaces it from 6.2.x on, matches a request against a list of HTTP methods. These compared the request method to the list verbatim, while the router serves a HEAD request with the GET handler, as HTTP semantics require.
This came after the incomplete fix of CVE-2026-45075 https://github.com/advisories/GHSA-6439-2f28-8p8q , which addressed the same gap in the #[IsGranted], #[IsSignatureValid] and #[IsCsrfTokenValid] attributes only.
Security rules configured to apply only to GET requests could therefore be bypassed by sending a HEAD request to the same URL. Although HEAD responses contain no body, attackers could still access response headers and trigger the controller's execution, including any side effects.
This issue also affects firewalls configured with methods: [GET]. A HEAD request would not match that firewall and could instead be handled by another matching firewall or no firewall at all. Applications using these vulnerable request matchers directly, including through a custom firewall request_matcher, could also be affected.
The issue affects symfony/http-foundation through v5.4.55, v6.x through 6.4.49, v7.x through v7.4.22, and v8.x through v8.1.10.
Affected Packages
https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v6.0.0-BETA1 <v6.4.50Fix Suggestion:
Update to version v6.4.50https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23Fix Suggestion:
Update to version v7.4.23https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v2.0.0BETA1 <v5.4.56 || >=v3.0.0-BETA1 <v5.4.56 || >=v4.0.0-BETA1 <v5.4.56 || >=v5.0.0-BETA1 <v5.4.56Fix Suggestion:
Update to version v5.4.56https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11Fix Suggestion:
Update to version v8.1.11symfony/symfony (PHP):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11Fix Suggestion:
Update to version v8.1.11symfony/symfony (PHP):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23Fix Suggestion:
Update to version v7.4.23symfony/http-foundation (PHP):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23Fix Suggestion:
Update to version v7.4.23symfony/http-foundation (PHP):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11Fix Suggestion:
Update to version v8.1.11symfony/symfony (PHP):
Affected version(s) >=2.0.4 <v5.4.56 || >=v2.0.9 <v5.4.56 || >=v4.0.0-BETA1 <v5.4.56 || >=v5.0.0-BETA1 <v5.4.56 || >=v3.0.0-BETA1 <v5.4.56Fix Suggestion:
Update to version v5.4.56symfony/symfony (PHP):
Affected version(s) >=v6.0.0-BETA1 <v6.4.50Fix Suggestion:
Update to version v6.4.50symfony/http-foundation (PHP):
Affected version(s) >=v6.0.0-BETA1 <v6.4.50Fix Suggestion:
Update to version v6.4.50symfony/http-foundation (PHP):
Affected version(s) >=2.0.4 <v5.4.56 || >=v4.0.0-BETA1 <v5.4.56 || >=v2.0.9 <v5.4.56 || >=v5.0.0-BETA1 <v5.4.56 || >=v3.0.0-BETA1 <v5.4.56Fix Suggestion:
Update to version v5.4.56Related Resources (5)
Do you need more information?
Contact UsCVSS v4
Base Score:
6.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.5
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Incorrect Authorization