Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-118517
Published:November 05, 2026
Updated:November 05, 2026
The Symfony HtmlSanitizer component UrlSanitizer parses URLs differently from browsers, allowing the allowLinkHosts() and allowMediaHosts() checks to be bypassed for URLs without a well-formed authority, resulting in untrusted hosts being referenced in sanitized output in Symfony versions 6.1.x prior to 6.4.50, 7.x prior to 7.4.23, and 8.x prior to 8.1.11. UrlSanitizer parses URLs with league/uri, which follows RFC 3986, while browsers follow the WHATWG URL standard. For URLs without a well-formed authority, such as http:evil.example, ///evil.example, or https://://evil.example/ the sanitizer finds no host, whereas browsers resolve them to evil.example. The guard added for CVE-2026-45066 missed the zero-slash form, and the host 0 was also skipped because PHP treats it as falsy. This is exploitable when a host allow-list is combined with allowRelativeLinks(true) or allowRelativeMedias(true). The default configuration is not affected.
Affected Packages
https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11
Fix Suggestion:
Update to version v8.1.11
https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23
Fix Suggestion:
Update to version v7.4.23
https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v6.1.0-BETA1 <v6.4.50
Fix Suggestion:
Update to version v6.4.50
symfony/html-sanitizer (PHP):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11
Fix Suggestion:
Update to version v8.1.11
symfony/html-sanitizer (PHP):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23
Fix Suggestion:
Update to version v7.4.23
symfony/html-sanitizer (PHP):
Affected version(s) >=v6.1.0-BETA1 <v6.4.50
Fix Suggestion:
Update to version v6.4.50
symfony/symfony (PHP):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11
Fix Suggestion:
Update to version v8.1.11
symfony/symfony (PHP):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23
Fix Suggestion:
Update to version v7.4.23
symfony/symfony (PHP):
Affected version(s) >=v6.1.0-BETA1 <v6.4.50
Fix Suggestion:
Update to version v6.4.50
Do you need more information?
Contact Us
CVSS v4
Base Score:
2.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
4.3
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Incomplete List of Disallowed Inputs
Interpretation Conflict