Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-118643
Published:October 28, 2026
Updated:November 02, 2026
n8n before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1 stores credential secrets in execution error data when operations fail in the Git, MongoDB Atlas Vector Store, and Google Cloud Storage nodes. Users who can view a workflow's executions but cannot read the credential can recover Git passwords or tokens, MongoDB database passwords, or Google access tokens from that data.
Affected Packages
https://github.com/n8n-io/n8n.git (GITHUB):
Affected version(s) >=n8n@2.0.0 <n8n@2.43.5
Fix Suggestion:
Update to version n8n@2.43.5
https://github.com/n8n-io/n8n.git (GITHUB):
Affected version(s) >=n8n@1.0.0 <n8n@1.123.85
Fix Suggestion:
Update to version n8n@1.123.85
https://github.com/n8n-io/n8n.git (GITHUB):
Affected version(s) =n8n@2.44.0 <n8n@2.44.1
Fix Suggestion:
Update to version n8n@2.44.1
@n8n/n8n-nodes-langchain (NPM):
Affected version(s) >=2.0.0 <2.43.3
Fix Suggestion:
Update to version 2.43.3
n8n (NPM):
Affected version(s) >=2.0.0-rc.0 <2.43.5
Fix Suggestion:
Update to version 2.43.5
@n8n/n8n-nodes-langchain (NPM):
Affected version(s) =2.44.0 <2.44.1
Fix Suggestion:
Update to version 2.44.1
n8n (NPM):
Affected version(s) >=1.0.0 <1.123.85
Fix Suggestion:
Update to version 1.123.85
n8n-nodes-base (NPM):
Affected version(s) >=1.0.0 <1.121.55
Fix Suggestion:
Update to version 1.121.55
n8n (NPM):
Affected version(s) =2.44.0 <2.44.1
Fix Suggestion:
Update to version 2.44.1
n8n-nodes-base (NPM):
Affected version(s) =2.44.0 <2.44.1
Fix Suggestion:
Update to version 2.44.1
n8n-nodes-base (NPM):
Affected version(s) >=2.0.0 <2.43.3
Fix Suggestion:
Update to version 2.43.3
@n8n/n8n-nodes-langchain (NPM):
Affected version(s) >=1.84.0 <1.122.60
Fix Suggestion:
Update to version 1.122.60
Do you need more information?
Contact Us
CVSS v4
Base Score:
5.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
HIGH
Subsequent System Integrity
HIGH
Subsequent System Availability
NONE
CVSS v3
Base Score:
8.2
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Weakness Type (CWE)
Generation of Error Message Containing Sensitive Information
EPSS
Base Score:
0.26