Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-118644
Published:October 28, 2026
Updated:November 02, 2026
n8n before 2.41.5 and 2.42.x before 2.42.2 passes a failed workflow's full execution context, including the identity of the user who started the run, to the configured error workflow. A project editor can set a colleague's workflow settings.errorWorkflow to an error workflow they own, inherit the colleague's identity when that workflow fails, and resolve the colleague's per-user dynamic credential secrets.
Affected Packages
https://github.com/n8n-io/n8n.git (GITHUB):
Affected version(s) >=n8n@2.42.0 <n8n@2.42.2
Fix Suggestion:
Update to version n8n@2.42.2
https://github.com/n8n-io/n8n.git (GITHUB):
Affected version(s) >=n8n@2.1.0 <n8n@2.41.5
Fix Suggestion:
Update to version n8n@2.41.5
n8n-core (NPM):
Affected version(s) >=2.1.0 <2.41.4
Fix Suggestion:
Update to version 2.41.4
n8n-core (NPM):
Affected version(s) >=2.42.0 <2.42.2
Fix Suggestion:
Update to version 2.42.2
n8n (NPM):
Affected version(s) >=2.1.0 <2.41.5
Fix Suggestion:
Update to version 2.41.5
n8n (NPM):
Affected version(s) >=2.42.0 <2.42.2
Fix Suggestion:
Update to version 2.42.2
Do you need more information?
Contact Us
CVSS v4
Base Score:
5
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
LOW
User Interaction
PASSIVE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
HIGH
Subsequent System Integrity
HIGH
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.7
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Weakness Type (CWE)
Incorrect Privilege Assignment
EPSS
Base Score:
0.20