Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-119025
Published:October 29, 2026
Updated:October 29, 2026
open 7.2.0 before 11.0.0 contains an OS command injection vulnerability that allows attackers to execute PowerShell code by supplying crafted URLs on Windows and WSL. Attackers can embed $(...) subexpressions in URLs, such as OAuth authorization_endpoint values from malicious MCP servers, which execute when index.js passes them unescaped to powershell -EncodedCommand.
Affected Packages
https://github.com/sindresorhus/open.git (GITHUB):
Affected version(s) >=v7.2.0 <v11.0.0 || >=v8.0.0 <v11.0.0 || >=v9.0.0 <v11.0.0 || >=v10.0.0 <v11.0.0
Fix Suggestion:
Update to version v11.0.0
open (NPM):
Affected version(s) >=8.0.0 <11.0.0 || >=7.2.0 <11.0.0 || >=9.0.0 <11.0.0 || >=10.0.0 <11.0.0
Fix Suggestion:
Update to version 11.0.0
Do you need more information?
Contact Us
CVSS v4
Base Score:
7.7
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.5
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Improper Neutralization of Special Elements used in an OS Command