CVE-2026-119118
Published:October 29, 2026
Updated:November 01, 2026
Crawl4AI before 0.9.5 contains an improper certificate validation vulnerability that allows network attackers to intercept crawls because Chromium always launches with --ignore-certificate-errors. Man-in-the-middle or DNS-controlling attackers can serve forged content to the crawler and read cookies and headers sent, while hard-coded --no-sandbox also overrides CRAWL4AI_CHROMIUM_SANDBOX.
Affected Packages
https://github.com/unclecode/crawl4ai.git (GITHUB):
Affected version(s) =v.3.72 <v0.9.5 || >=v0.3.745 <v0.9.5 || >=vr0.6.0rc1 <v0.9.5Fix Suggestion:
Update to version v0.9.5crawl4ai (PYTHON):
Affected version(s) >=0.3.7 <0.9.5Fix Suggestion:
Update to version 0.9.5Related Resources (2)
Do you need more information?
Contact UsCVSS v4
Base Score:
8.3
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
HIGH
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
6.5
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
HIGH
Availability
NONE
Weakness Type (CWE)
Improper Certificate Validation
EPSS
Base Score:
0.19