Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-119130
Published:October 29, 2026
Updated:October 30, 2026
Wasmtime before 36.0.18, 37.0.0 before 48.0.6, and 49.0.0 before 49.0.3 does not verify that set-path-with-query values in wasmtime-wasi-http are paths, so absolute-form URLs are written verbatim as the HTTP/1.1 request target while the connection uses the allowed authority. A malicious guest can supply an absolute URL that a forward proxy or gateway at that authority honors, reaching hosts disallowed by embedder filtering policies.
Affected Packages
https://github.com/bytecodealliance/wasmtime.git (GITHUB):
Affected version(s) >=v49.0.0-rc.1 <v49.0.3
Fix Suggestion:
Update to version v49.0.3
https://github.com/bytecodealliance/wasmtime.git (GITHUB):
Affected version(s) >=v37.0.0 <v48.0.6 || >=v38.0.1 <v48.0.6 || >=v39.0.0 <v48.0.6 || >=v40.0.0 <v48.0.6 || >=v41.0.0 <v48.0.6 || >=v42.0.0 <v48.0.6 || >=v43.0.0 <v48.0.6 || >=v44.0.0 <v48.0.6 || >=v45.0.0 <v48.0.6 || >=v46.0.0 <v48.0.6 || >=v47.0.0 <v48.0.6 || >=v48.0.0 <v48.0.6
Fix Suggestion:
Update to version v48.0.6
https://github.com/bytecodealliance/wasmtime.git (GITHUB):
Affected version(s) >=v9.0.0 <v36.0.18 || >=v10.0.0 <v36.0.18 || >=v11.0.0 <v36.0.18 || >=v12.0.0 <v36.0.18 || >=v13.0.0 <v36.0.18 || >=v14.0.0 <v36.0.18 || >=v15.0.0 <v36.0.18 || =v16.0.0 <v36.0.18 || >=v17.0.0 <v36.0.18 || >=v18.0.0 <v36.0.18 || >=v19.0.0 <v36.0.18 || >=v20.0.0 <v36.0.18 || >=v21.0.0 <v36.0.18 || >=v22.0.0 <v36.0.18 || >=v23.0.0 <v36.0.18 || >=v24.0.0 <v36.0.18 || >=v25.0.0 <v36.0.18 || >=v26.0.0 <v36.0.18 || =v27.0.0 <v36.0.18 || >=v28.0.0 <v36.0.18 || >=v29.0.0 <v36.0.18 || >=v30.0.0 <v36.0.18 || =v31.0.0 <v36.0.18 || >=v32.0.0 <v36.0.18 || >=v33.0.0 <v36.0.18 || >=v34.0.0 <v36.0.18 || =v35.0.0 <v36.0.18 || >=v36.0.0 <v36.0.18
Fix Suggestion:
Update to version v36.0.18
https://github.com/bytecodealliance/wasmtime.git (GITHUB):
Affected version(s) =v50.0.0-rc.1 <v50.0.0
Fix Suggestion:
Update to version v50.0.0
wasmtime-wasi-http (RUST):
Affected version(s) >=37.0.0 <48.0.6 || >=38.0.0 <48.0.6 || >=39.0.0 <48.0.6 || >=40.0.0 <48.0.6 || >=41.0.0 <48.0.6 || >=42.0.0 <48.0.6 || >=43.0.0 <48.0.6 || >=44.0.0 <48.0.6 || >=45.0.0 <48.0.6 || >=46.0.0 <48.0.6 || >=47.0.0 <48.0.6 || >=48.0.0 <48.0.6
Fix Suggestion:
Update to version 48.0.6
wasmtime-wasi-http (RUST):
Affected version(s) >=9.0.0 <36.0.18 || >=10.0.0 <36.0.18 || >=11.0.0 <36.0.18 || >=12.0.0 <36.0.18 || >=13.0.0 <36.0.18 || >=14.0.0 <36.0.18 || >=15.0.0 <36.0.18 || =16.0.0 <36.0.18 || >=17.0.0 <36.0.18 || >=18.0.0 <36.0.18 || >=19.0.0 <36.0.18 || >=20.0.0 <36.0.18 || >=21.0.0 <36.0.18 || >=22.0.0 <36.0.18 || >=23.0.0 <36.0.18 || >=24.0.0 <36.0.18 || >=25.0.0 <36.0.18 || >=26.0.0 <36.0.18 || =27.0.0 <36.0.18 || >=28.0.0 <36.0.18 || >=29.0.0 <36.0.18 || >=30.0.0 <36.0.18 || =31.0.0 <36.0.18 || >=32.0.0 <36.0.18 || >=33.0.0 <36.0.18 || >=34.0.0 <36.0.18 || =35.0.0 <36.0.18 || >=36.0.0 <36.0.18
Fix Suggestion:
Update to version 36.0.18
wasmtime-wasi-http (RUST):
Affected version(s) >=49.0.0-rc.1 <49.0.3
Fix Suggestion:
Update to version 49.0.3
wasmtime-wasi-http (RUST):
Affected version(s) =50.0.0-rc.1 <50.0.0
Fix Suggestion:
Update to version 50.0.0
Do you need more information?
Contact Us
CVSS v4
Base Score:
2.1
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
PRESENT
Privileges Required
LOW
User Interaction
PASSIVE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
2.6
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Weakness Type (CWE)
Improper Input Validation
EPSS
Base Score:
0.24