Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-119146
Published:October 30, 2026
Updated:November 04, 2026
ProFTPD before 1.3.9e and 1.3.10rc5 contains a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap that allows remote attackers to overwrite static buffers. Attackers can send FTP command arguments longer than 1024 bytes, without authentication if pre-login commands are rewritten, to corrupt session memory and crash the session.
Affected Packages
https://github.com/proftpd/proftpd.git (GITHUB):
Affected version(s) >=v1.3.10rc1 <v1.3.10rc5
Fix Suggestion:
Update to version v1.3.10rc5
https://github.com/proftpd/proftpd.git (GITHUB):
Affected version(s) >=v1.3.5a <v1.3.9e || >=v1.3.6rc1 <v1.3.9e || >=v1.3.7rc1 <v1.3.9e || >=v1.3.8rc1 <v1.3.9e || >=v1.3.9rc1 <v1.3.9e
Fix Suggestion:
Update to version v1.3.9e
Do you need more information?
Contact Us
CVSS v4
Base Score:
6.3
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
LOW
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
5.6
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Weakness Type (CWE)
Buffer Copy without Checking Size of Input
EPSS
Base Score:
0.46