Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-119282
Published:October 29, 2026
Updated:October 30, 2026
Nx is a monorepo solution for TypeScript and polyglot codebases. From 22.0.2 until 22.7.9 and 23.1.2 for @nx/maven, and from 21.0.0 until 22.7.9 and 23.1.2 for @nx/gradle, the plugins' project-graph analyzers launch through a shell and interpolate plugin options from nx.json into command arguments. The @nx/maven targetNamePrefix value and arbitrary @nx/gradle option names or values can therefore be interpreted as shell syntax whenever an nx command constructs the project graph. A user who runs Nx in an attacker-controlled repository or pull request can execute injected commands with the user's privileges, while workspaces that register neither affected plugin are not exposed to this path. Remediation requires upgrading both nx and each affected plugin to matching releases because the plugin fix depends on code in the nx package. This issue is fixed in versions 22.7.9 and 23.1.2.
Affected Packages
https://github.com/nrwl/nx.git (GITHUB):
Affected version(s) >=21.0.0-beta.7 <22.7.9 || >=21.0.0 <22.7.9 || >=22.0.0-beta.0 <22.7.9 || >=22.0.0 <22.7.9
Fix Suggestion:
Update to version 22.7.9
https://github.com/nrwl/nx.git (GITHUB):
Affected version(s) >=23.0.0-beta.0 <23.1.2 || >=23.0.0 <23.1.2
Fix Suggestion:
Update to version 23.1.2
@nx/gradle (NPM):
Affected version(s) >=21.0.0 <22.7.9
Fix Suggestion:
Update to version 22.7.9
@nx/gradle (NPM):
Affected version(s) >=23.0.0-beta.0 <23.1.2 || >=23.0.0 <23.1.2
Fix Suggestion:
Update to version 23.1.2
@nx/maven (NPM):
Affected version(s) >=22.0.2 <22.7.9
Fix Suggestion:
Update to version 22.7.9
@nx/maven (NPM):
Affected version(s) >=23.0.0-beta.0 <23.1.2 || >=23.0.0 <23.1.2
Fix Suggestion:
Update to version 23.1.2
@nx/gradle (NPM):
Affected version(s) >=21.0.0-beta.7 <22.7.9 || =21.0.0 <22.7.9 || >=21.0.0-canary.20250424-e23b25f <22.7.9 || >=22.0.0-beta.0 <22.7.9 || >=22.0.0 <22.7.9
Fix Suggestion:
Update to version 22.7.9
Do you need more information?
Contact Us
CVSS v4
Base Score:
7.3
Attack Vector
LOCAL
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
PASSIVE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.8
Attack Vector
LOCAL
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Weakness Type (CWE)
Improper Neutralization of Special Elements used in an OS Command
Improper Neutralization of Argument Delimiters in a Command