CVE-2026-120236
Published:November 01, 2026
Updated:November 04, 2026
A vulnerability was detected in ag-ui-protocol ag-ui up to 0.0.58. Affected by this vulnerability is an unknown functionality of the component Transport Decoder Handler. The manipulation results in improper input validation. The attack may be launched remotely. The exploit is now public and may be used. The patch is identified as 660182b973a44b8eda5484b14b88eb9cc251edc4. It is suggested to upgrade the affected component.
Affected Packages
https://github.com/ag-ui-protocol/ag-ui.git (GITHUB):
Affected version(s) >=release/2026-03-28 <release/2026-09-23Fix Suggestion:
Update to version release/2026-09-23@ag-ui/client (NPM):
Affected version(s) >=0.0.27 <1.0.0 || =0.1.1-canary.beta.0 <1.0.0Fix Suggestion:
Update to version 1.0.0Related Resources (11)
Do you need more information?
Contact UsCVSS v4
Base Score:
2.1
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
LOW
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
Exploit Maturity
POC
CVSS v3
Base Score:
6.3
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Exploit Maturity
PROOF-OF-CONCEPT
Weakness Type (CWE)
Improper Input Validation
EPSS
Base Score:
0.27