Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-121967
Published:November 04, 2026
Updated:November 06, 2026
Coder 2.28.0 before 2.29.22, 2.30.0 before 2.34.13, 2.35.0 before 2.35.10, 2.36.0 before 2.36.8, 2.37.0 before 2.37.5, and 2.38.0 before 2.38.1 contains a path traversal vulnerability in the AI Gateway passthrough router, which forwards percent-encoded dot segments upstream without rejecting them. Authenticated users can send paths such as %2e%2e or ..%2F under allowlisted prefixes to reach unintended provider endpoints using the deployment's centrally managed provider key.
Affected Packages
https://github.com/coder/coder.git (GITHUB):
Affected version(s) >=v2.30.0 <v2.34.13
Fix Suggestion:
Update to version v2.34.13
https://github.com/coder/coder.git (GITHUB):
Affected version(s) >=v2.28.0 <v2.29.22
Fix Suggestion:
Update to version v2.29.22
https://github.com/coder/coder.git (GITHUB):
Affected version(s) >=v2.37.0 <v2.37.5
Fix Suggestion:
Update to version v2.37.5
https://github.com/coder/coder.git (GITHUB):
Affected version(s) >=v2.36.0 <v2.36.8
Fix Suggestion:
Update to version v2.36.8
https://github.com/coder/coder.git (GITHUB):
Affected version(s) >=v2.35.0 <v2.35.10
Fix Suggestion:
Update to version v2.35.10
https://github.com/coder/coder.git (GITHUB):
Affected version(s) =v2.38.0 <v2.38.1
Fix Suggestion:
Update to version v2.38.1
github.com/coder/coder/v2 (GO):
Affected version(s) >=v2.30.0 <v2.34.13
Fix Suggestion:
Update to version v2.34.13
github.com/coder/coder/v2 (GO):
Affected version(s) >=v2.36.0 <v2.36.8
Fix Suggestion:
Update to version v2.36.8
github.com/coder/coder/v2 (GO):
Affected version(s) >=v2.35.0 <v2.35.10
Fix Suggestion:
Update to version v2.35.10
github.com/coder/coder/v2 (GO):
Affected version(s) >=v2.28.0 <v2.29.22
Fix Suggestion:
Update to version v2.29.22
github.com/coder/coder/v2 (GO):
Affected version(s) >=v2.37.0 <v2.37.5
Fix Suggestion:
Update to version v2.37.5
github.com/coder/coder/v2 (GO):
Affected version(s) =v2.38.0 <v2.38.1
Fix Suggestion:
Update to version v2.38.1
Do you need more information?
Contact Us
CVSS v4
Base Score:
2.3
Attack Vector
NETWORK
Attack Complexity
HIGH
Attack Requirements
PRESENT
Privileges Required
LOW
User Interaction
NONE
Vulnerable System Confidentiality
LOW
Vulnerable System Integrity
LOW
Vulnerable System Availability
NONE
Subsequent System Confidentiality
LOW
Subsequent System Integrity
LOW
Subsequent System Availability
NONE
CVSS v3
Base Score:
4.9
Attack Vector
NETWORK
Attack Complexity
HIGH
Privileges Required
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Weakness Type (CWE)
Improper Limitation of a Pathname to a Restricted Directory
EPSS
Base Score:
0.26