CVE-2026-121971
Published:November 04, 2026
Updated:November 06, 2026
The component ScopingHttpClient in Symfony HttpClient merges the options of its default scope (such as auth_bearer or auth_basic) into a request before resolving a relative URL against the base_uri, allowing a network-path reference such as "//evil.example/steal" to be sent to another origin together with the default scope’s credentials, and resulting in potential disclosure of those credentials to an attacker-controlled server. This affects Symfony in versions 5.x prior to 5.4.56, 6.x prior to 6.4.50, 7.x prior to 7.4.23, and 8.x prior to 8.1.11.
The resolved URL falls outside the origin of the base URI, yet it keeps the merged options, whereas the absolute spelling "https://evil.example/steal" receives none. The same happens with a different port or user-info part on the same host.
This is reachable whenever an attacker controls the beginning of a URL passed to a client built with a base_uri and credentials, including those created with HttpClient::createForBaseUri() or configured under framework.http_client.scoped_clients.
To solve the issue, after resolving a relative URL against the base URI of the default scope, ScopingHttpClient now compares the scheme and authority of the result with those of the base URI, parsed the way the request is sent.
Affected Packages
https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23Fix Suggestion:
Update to version v7.4.23https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v6.0.0-BETA1 <v6.4.50Fix Suggestion:
Update to version v6.4.50https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v4.3.0-BETA1 <v5.4.56 || >=v5.0.0-BETA1 <v5.4.56Fix Suggestion:
Update to version v5.4.56https://github.com/symfony/symfony.git (GITHUB):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11Fix Suggestion:
Update to version v8.1.11symfony/http-client (PHP):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11Fix Suggestion:
Update to version v8.1.11symfony/symfony (PHP):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23Fix Suggestion:
Update to version v7.4.23symfony/http-client (PHP):
Affected version(s) >=v4.3.0-BETA1 <v5.4.56 || >=v5.0.0-BETA1 <v5.4.56Fix Suggestion:
Update to version v5.4.56symfony/symfony (PHP):
Affected version(s) >=v5.0.0-BETA1 <v5.4.56 || >=v4.3.0-BETA1 <v5.4.56Fix Suggestion:
Update to version v5.4.56symfony/symfony (PHP):
Affected version(s) >=v6.0.0-BETA1 <v6.4.50Fix Suggestion:
Update to version v6.4.50symfony/http-client (PHP):
Affected version(s) >=v6.0.0-BETA1 <v6.4.50Fix Suggestion:
Update to version v6.4.50symfony/http-client (PHP):
Affected version(s) >=v7.0.0-BETA1 <v7.4.23Fix Suggestion:
Update to version v7.4.23symfony/symfony (PHP):
Affected version(s) >=v8.0.0-BETA1 <v8.1.11Fix Suggestion:
Update to version v8.1.11Related Resources (6)
Do you need more information?
Contact UsCVSS v4
Base Score:
8.2
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
NONE
Vulnerable System Availability
NONE
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.5
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Weakness Type (CWE)
EPSS
Base Score:
0.25