Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-122058
Published:November 04, 2026
Updated:November 05, 2026
This module introduces an OAuth 2.0 authorization server, which can be configured to protect your Drupal instance with access tokens, or allow clients to request new access tokens and refresh them. The module doesn't sufficiently restrict access to consumer configuration. Users who can create or edit consumers can potentially configure malicious consumers and obtain tokens with additional privileges. This can allow them to access the site as another user, up to full administrative access. This vulnerability is mitigated by the fact that an attacker must have a role with the Add consumer entities or Update own consumer entities permissions.
Affected Packages
https://git.drupalcode.org/project/simple_oauth.git (SCM_GIT):
Affected version(s) >=6.0.0-alpha1 <6.0.10
Fix Suggestion:
Update to version 6.0.10
https://git.drupalcode.org/project/simple_oauth.git (SCM_GIT):
Affected version(s) >=8.x-3.0-beta1 <5.2.6 || >=8.x-4.0 <5.2.6 || >=5.0.0 <5.2.6
Fix Suggestion:
Update to version 5.2.6
https://git.drupalcode.org/project/simple_oauth.git (SCM_GIT):
Affected version(s) >=6.1.0 <6.1.4
Fix Suggestion:
Update to version 6.1.4
Do you need more information?
Contact Us
CVSS v4
Base Score:
8.6
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
HIGH
User Interaction
NONE
Vulnerable System Confidentiality
HIGH
Vulnerable System Integrity
HIGH
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
7.2
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH