Mend.io Vulnerability Database
The largest open source vulnerability database
What is a Vulnerability ID?
New vulnerability? Tell us about it!
CVE-2026-61846
Published:October 30, 2026
Updated:October 30, 2026
Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, Crass recursively parses "CSS simple blocks and functions" without a depth guard. An attacker-controlled CSS value containing deeply nested blocks or functions can recurse until Ruby raises "SystemStackError": stack level too deep, or cause excessive memory usage. Version 1.0.7 adds a configurable depth limit with a conservative default. This issue is fixed in version 1.0.7.
Affected Packages
https://github.com/rgrove/crass.git (GITHUB):
Affected version(s) >=v0.0.1 <v1.0.7 || >=v1.0.0 <v1.0.7
Fix Suggestion:
Update to version v1.0.7
crass (RUBY):
Affected version(s) >=1.0.0 <1.0.7 || >=0.0.1 <1.0.7
Fix Suggestion:
Update to version 1.0.7
crass (RUBY):
Affected version(s) >=0.0.1 <1.0.7
Fix Suggestion:
Update to version 1.0.7
Do you need more information?
Contact Us
CVSS v4
Base Score:
6.3
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
PRESENT
Privileges Required
NONE
User Interaction
NONE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
NONE
Vulnerable System Availability
LOW
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
LOW
CVSS v3
Base Score:
5.8
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
NONE
Integrity
NONE
Availability
LOW
Weakness Type (CWE)
Uncontrolled Recursion
Uncontrolled Resource Consumption