CVE-2026-83525
Published:October 28, 2026
Updated:October 29, 2026
Incorrect operator (CWE-480) in the FetchSnapshot RPC handler
in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2
on all platforms allows an authenticated attacker with
CLUSTER_ACTION privilege to cause a denial of service
(controller process termination) via a crafted
FetchSnapshotRequest with an empty topics array or a topic
with no partitions.
Users are recommended to upgrade to version 4.2.2, 4.3.2, or
4.4.0, which fix this issue. Users on unsupported branches
(4.1.x and earlier) should upgrade to 4.2.2 or later.
Affected Packages
https://github.com/apache/kafka.git (GITHUB):
Affected version(s) >=4.2.0-rc0 <4.2.2Fix Suggestion:
Update to version 4.2.2https://github.com/apache/kafka.git (GITHUB):
Affected version(s) >=4.3.0-rc0 <4.3.2Fix Suggestion:
Update to version 4.3.2org.apache.kafka:kafka-raft (JAVA):
Affected version(s) >=4.2.0 <4.2.2Fix Suggestion:
Update to version 4.2.2org.apache.kafka:kafka-raft (JAVA):
Affected version(s) >=4.3.0 <4.3.2Fix Suggestion:
Update to version 4.3.2Related Resources (3)
Do you need more information?
Contact UsCVSS v4
Base Score:
6.9
Attack Vector
NETWORK
Attack Complexity
LOW
Attack Requirements
NONE
Privileges Required
HIGH
User Interaction
NONE
Vulnerable System Confidentiality
NONE
Vulnerable System Integrity
NONE
Vulnerable System Availability
HIGH
Subsequent System Confidentiality
NONE
Subsequent System Integrity
NONE
Subsequent System Availability
NONE
CVSS v3
Base Score:
4.9
Attack Vector
NETWORK
Attack Complexity
LOW
Privileges Required
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Weakness Type (CWE)
Use of Incorrect Operator